Back to overview
Resolved

Internet connectivity outage across-campus

May 22, 2026 at 8:42am UTC
Affected services
Wired
WiFi
VPN
Telephony

Resolved
May 22, 2026 at 9:26am UTC

The campus network has now been restored, and all buildings are reporting positively

Created
May 22, 2026 at 8:42am UTC

Staff and students are reporting that they have been kicked off the network while on campus. Users off campus were unable to connect to the VPN.