Back to overview
Resolved
ESS Unavailable
May 21, 2026 at 10:16am UTC
Affected services
HR System
Resolved
May 21, 2026 at 10:32am UTC
Service has been restored.
Affected services
Created
May 21, 2026 at 10:16am UTC
ESS is showing the following error and inaccessible:
Sorry, the requested action was rejected by the MHR hosted security systems.
We are working on this and looking into restoring service.
Affected services