Back to overview
Resolved
TurnItIn
May 19, 2026 at 1:20pm UTC
Affected services
Moodle - moodle.port.ac.uk
Moodle
Resolved
May 19, 2026 at 1:40pm UTC
This has now been resolved
Affected services
Created
May 19, 2026 at 1:20pm UTC
Turnitin is currently experiencing technical difficulties.
You can view the Turnitin service status page for the latest updates:
Affected services