Back to overview
Degraded

Phishing

Apr 29, 2026 at 9:30am UTC
Affected services
Google Workspace
Microsoft 365

Resolved
Apr 29, 2026 at 3:00pm UTC

Offending emails have been removed.

Please remain vigilant and report anything suspicious.

Created
Apr 29, 2026 at 9:30am UTC

Several reports of phishing emails have been received. These emails are asking you to click SharePoint links and offering goods/services.

Reminder to NOT click on any links or emails you are not expecting. We are investigating and removing the emails from user inboxes before they are read, where possible, but this also relies heavily on some sense checks by each user.

In cases where you think there is a scam, spam or phishing attempt you can always look over a few things in the email; Spelling errors, who is the sender, are they asking you to click a link, did you expect the correspondence etc.

If you believe it's phishing or spam, please right click the email and 'report' it as Phishing/Junk. You can also choose to block the sender in the same context menu. With these reports it will flag on our system and notify the relevant team to investigate.

Thank you for being vigilant, and if you wish to query any we're more than happy to discuss it over the phone on a case by case basis.