Back to overview
Resolved
R4 Dentistry Update - Thursday 30 July 2026
Jul 30, 2026 at 12:00pm UTC
–
Jul 30, 2026 at 4:00pm UTC
Affected services
Dentistry (R4)
Resolved
Jul 30, 2026 at 4:00pm UTC
Maintenance ended
Affected services
Created
Jul 30, 2026 at 12:00pm UTC
R4 Dentistry will be upgraded to version 9.10 on Thursday 30 July, from 1pm. The system will be unavailable during this work
Affected services