Back to overview
Resolved

Park Building - Internet and Phone outage

Jun 2, 2026 at 7:19am UTC
Affected services
Wired
WiFi
VPN
Telephony

Resolved
Jun 2, 2026 at 8:09am UTC

Park building is now back to normal functionality. Internet and Phone lines should be operational.

Created
Jun 2, 2026 at 7:19am UTC

It has been reported that the Park building communication cabinet is not receiving power, stopping the internet and phone lines from working in the building