Back to overview
Resolved

iTrent 10.60.00 Upgrade Thursday 2 July

Jul 2, 2026 at 7:30am UTC
Affected services
HR System

Resolved
Jul 2, 2026 at 7:30am UTC

Manager Self Service, Employee Self Service and Web Recruitment will be unavailable on Thursday 2 July whilst the upgrade is performed by MHR