Back to overview
Resolved
R4 Dentistry Update Wednesday 3 June
Jun 3, 2026 at 12:00pm UTC
Affected services
Dentistry (R4)
Resolved
Jun 3, 2026 at 12:00pm UTC
Our supplier will be running the R4 9.02 Update on Wednesday 3 June from 1pm. The system will be unavailable during this work.
Affected services