Back to overview
Maintenance
Live Services Security Patching
Apr 24, 2026 at 11:00pm UTC
–
Apr 25, 2026 at 11:00am UTC
Affected services
HR System
Resolved
Apr 25, 2026 at 11:00am UTC
Maintenance ended
Affected services
Created
Apr 24, 2026 at 11:00pm UTC
Please note that MHR Cloud Services will be undertaking planned Live Services Security Patching on 25/04/2026. This maintenance activity will take place on Saturday between 0001 and 1200 and will affect LIVE.
Please ensure that you complete any work and exit the systems by the time specified above. We apologise for any inconvenience this work may cause.
Affected services